Ansible and Cisco ios module “Incompatible version (2.99 instead of 2.0)”

I came around this bug with a Cisco switch when I was trying to run a Ansible playbook, and got the above error message, the tl;dr is that I was able to overcome this...