Ansible and Cisco ios module “Incompatible version (2.99 instead of 2.0)”

I came around this bug with a Cisco switch when I was trying to run a Ansible playbook, and got the above error message, the tl;dr is that I was able to overcome this problem by running the command `ip ssh version 2`

Router#show ip ssh

SSH Enabled - version 2.99

Authentication timeout: 120 secs; Authentication retries: 3

Router#

If version “2.99” is reported, proceed to configure the required SSH version, ie:

Router#show ip ssh
Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#ip ssh version 2

Router(config)#end

Resources

  • https://community.cisco.com/t5/vpn-and-anyconnect/ssh-version-2-99/td-p/1066921

You may also like...

Leave a Reply

Your email address will not be published.